Visual Studio 2017 versión 15.7.6 ahora es compatible con JDK 8 Update 181 8u181

Ventanas / Visual Studio 2017 versión 15.7.6 ahora es compatible con JDK 8 Update 181 8u181 1 minuto de lectura

Visual Studio 2017

Visual Studio 2017 se actualizó a una nueva versión, la 15.7.6, que agrega algunas funciones nuevas al tiempo que corrige algunos errores que impedían que los usuarios usaran la aplicación.

Principalmente, esta nueva versión agrega soporte para Java Development Kit 8 (JDK versión 8u181) que agrega una gran cantidad de características nuevas a la programación Java, incluida la adición de soporte para declaraciones for-each, métodos predeterminados y estáticos en interfaces, interfaces funcionales, declaraciones lamda y mejoras en las API de recopilación, simultaneidad y tiempo de Java.



En esta nueva versión, se han detectado y solucionado tres errores:



  • Visual C ++ Redistributable 2017 no informa el estado de instalación en una ubicación de registro específica
  • En 15.7, los usuarios pueden ver que las extensiones se cargan sin todos sus activos y hacen que Visual Studio se bloquee.
  • Visual Studio 2017, versión 15.7.5, se bloquea al abrir una solución

El primer error involucraba el manejo incorrecto del registro del C ++ Redistribuible al instalar o actualizar a una nueva versión, ocurría un error que se quejaba de no poder encontrar la clave correcta por haber sido borrada. Los usuarios que ingresaron datos en la ubicación del registro anterior se actualizaron y sus soluciones se rompieron debido a este error. El segundo error ocurrió cuando los usuarios estaban cargando extensiones y no todos sus activos se cargarían con ellos, lo que provocó que Visual Studio se bloqueara, lo que conduce al tercer y último error que provocó que Visual Studio versión 15.7.5 se bloqueara al iniciarse al cargar una solución o tratando de crear una nueva.



Además de esos cambios, Microsoft también ha lanzado una función de seguridad de .NET Core Bypass Vulernability que ilustra una vulnerabilidad de seguridad donde .NET Core no valida correctamente los certificados. “Un atacante que aproveche con éxito esta vulnerabilidad podría presentar un certificado caducado cuando sea desafiado. Esta actualización corrige la vulnerabilidad al corregir la forma en que .NET Core maneja la validación de certificados '. Si desea ver más información sobre esto, haga clic aquí para ir al Centro de respuesta de seguridad de Microsoft.

Se pueden leer el registro de cambios completo y las notas de la versión aquí

3 de agosto de 2018 1 minuto de lectura